fbpx

lenovo ideapad y480 disassembly

My ideapad y480 was shutting down while using the dedicated graphics, I know it was a heating issue. I left it unresolved for a few weeks, until I finally got frustrated enough and just began to disassemble the thing. My first thought was that maybe the fan and motherboard was really dusty and it was preventing proper air flow (this was best case scenario), my next thought was maybe the cpu/gpu didn’t have adequate thermal compound.

After unraveling the laptop, I came to the conclusion that dust was not the issue. Surprisingly enough the internals of the laptop was pretty clean and not much dust. I did have a can of compressed air so I did thoroughly clean inside. What the issue was, was there was an abysmal amount of thermal paste on the gpu. The cpu had a decent amount, but the gpu was completely dry. So spent more than I should have at best buy buying some thermal compound. After cleaning gpu/cpu I began to reassemble the laptop. I thought to myself this was a pretty successful, encountering problem and properly assessing the issue.

power ribbon

After putting the laptop back together I was faced with the issue of the laptop not powering on at all. I thought ok, something wasn’t hooked up right, I take it all apart and find nothing out of the ordinary, but apparently I didn’t secure something because this time it powered back on, but the hdd apparently got wiped out. I was able to get to bios, I made a flash with linux. After I got linux up and running I installed windoze 10, and began to realize that a media card with usb/headphone wasn’t working. I knew exactly where that was and I disassembled the laptop again. I realized that a little plastic piece had snapped off which secured the card. This was no victory for me, as much as I use this laptop on the go and having sound for headphones is an absolute necessity. Unfortunately the card connects to the motherboard, and the plastic piece snapped off on the motherboard.

During the reassembly I realized now that the laptop does not power on. I figured it must be the little ribbon that connects from the palm rest frame to the power button from the motherboard. I ordered the part and sure enough it powers back on, no problem. This of course still doesn’t solve the headphone predicament. I went ahead and bought a new motherboard, this opens a whole new can of worms.

little plastic piece that broke off

I get the motherboard put everything back together and now it powers on but I get nothing more than a black screen. I try the old motherboard, and it fires back up no problem. I am confused and insist it must be something wrong with the new board I  had bought. But I switch around ram on the new board and it finally fires up. I had to try each stick of ram individually before it would post into bios. I of course get no sound from headphones have to take it apart and re-attach the card, and this time I have successfully solved all problems. The laptop now operates under high stress at reasonable temperatures and it has all working functions as if bought brand new.

I cannot tell you how many times I wanted to throw this thing in the trash, but I had been able to identify each problem and know the solution. Of course encountering issues where it wouldn’t power on at all, or would power but no bios. These were all things I wasn’t sure how to assess. Fortunately I had the tools to be able to properly diagnose.

EDIT: during this process I broke the little plastic piece for headphone/usb, I broke the little ribbon for power and I also broke the little ribbon to keyboard that allows the keyboard to be back lit light. Only thing being absolutely necessary was the power.